Topic: Salutations for multiple language installation - inconsistencies  (Read 37685 times)

We have a problem with the salutations in our conference with a multi-language setup in English and German (ConfTool Pro).
After initial installation we had German added as second language.
The salutations do not comply with the language chosen in the main installation. Only the English salutations are shown, both on the registration form and also in the the bulk e-mail functions.
We tried "wording and phrases" to fix the issue, but it did not help.

Is there something we can do?

A short technical explanation:
The salutations are taken from a separate table in the ConfTool Pro database. These database entries are created during the first system call (initialization), using the wording found in the corresponding language definitions.
If the language specifications are changed after the first access to the system, there will be inconsistencies in the database table "salutations".

You can manually update the salutations at any time here:
Overview => Settings => Settings for User Registration => Manage Titles / Salutations

Alternatively, you can re-initialize the salutation table with the default entries, by going to the above page and adding &clear=yes to the URL in the address bar. The full URL will look like this:
www conftool.net/yourconference/index.php?page=adminToolSalutations&clear=yes

What happens is that the database table "salutations" is emptied using the command: "delete from salutations;".
Please remember to logout and login again to see the results of this process in your installation.